Назначение программы

Программа Архиватор (в дальнейшем программа) предназначена для чтения данных из тепловычислителей ТВ7, расходомеров Питерфлоу РС и преобразователей измерительных АДИ, производства ЗАО "ТЕРМОТРОНИК", и подготовки отчетных ведомостей о тепло- и водопотреблении.

Программа Архиватор обеспечивает:

·считывание данных из вычислителей ТВ7:

§текущие и итоговые параметры;

§архивные параметры (часовые, суточные, месячные и итоговые);

§параметры настройки (содержимое базы данных);

§архивы событий;

·считывание данных из расходомеров Питерфлоу РС:

§архивные параметры (минутные, часовые и суточные);

§параметры настройки;

§архив событий;

·считывание данных из преобразователей измерительных АДИ:

§архивные параметры (часовые и суточные);

§параметры настройки;

§архив событий;

·считывание данных из приборов по запросу оператора или автоматически по расписанию;

·сохранение данных в базе данных Microsoft Access;

·импорт данных из баз данных;

·импорт данных из устройств переноса данных (планшетный компьютер и накопительный пульт);

·синхронизацию базы данных ПК и устройств переноса данных;

·подготовку отчетных ведомостей о тепло- и водопотреблении;

·конвертирование отчетных ведомостей в формат Excel;

·вывод отчетных ведомостей на печать по шаблонам.


Требования к оборудованию

Программа функционирует под управлением операционной системы Windows XP и выше.

Рабочий каталог программы должен быть разрешен на запись.


Установка программы

Программа поставляется в виде исполняемого файла и не требует установки.

Внимание! Файл с программой следует сохранять в отдельной папке.

При первом запуске программы в рабочем каталоге создаются:

·папка DB с базой данных;

·папка backup с резервной копией базы данных;

·файл справки

Примечание Резервная копия базы данных создается при запуске программы, если с момента последнего обновления прошло больше недели.


Интерфейс пользователя

При запуске программы на экран выводится главное окно программы

Программа имеет стандартный интерфейс, включающий панель меню и панель управления. Команды на панели управления дублируют команды меню.

Дополнительно в главном окне отображаются строка состояния, в которой отображаются результаты выполнения команд.


Опрос прибора учета

Программа рассчитана на чтение архивных данных за весь диапазон дат, находящихся в памяти приборов. Это позволяет хранить в базе данных (файл Data.mdb) непрерывный архив. В связи с этим, при первом обращении к прибору время опроса прибора может быть большим. При последующих обращениях к прибору досчитываются только вновь сформированные данные.

Программа может опрашивать только приборы, зарегистрированные в базе данных.

Опрос производится по каналу связи, заданному в настройках свойств прибора (вкладка "Соединение") (см. Свойства прибора учета).

Примечание Независимо от типа соединения и настроек при подключении вычислителя ТВ7 к ПК по USB считывание данных происходит автоматически.

Примечание При подключении вычислителя ТВ7 к ПК по интерфейсу USB программа самостоятельно предлагает опросить прибор. А если прибор учета еще не добавлен в базу, то предлагает внести данные в базу приборов.

Перед началом опроса прибора следует:

- Добавить прибор учета в базу данных (см. Добавления прибора учета);

- Подключить прибор к компьютеру в соответствии с выбранным типом соединения.

Далее:

1.Выбрать прибор учета из списка

2.По щелчку правой кнопки мыши выбрать команду "Опросить прибор" или нажать кнопку OprosBut .

3. Или выделить требуемый прибор и в меню "Приборы учета" выбрать команду "Опросить прибор".

Программа установит связь с прибором и считает настройки и архивные данные.

Все считанные данные автоматически заносятся в базу данных.

Далее можно переходить к формированию отчетов (см. Формирование отчетов).

Если в свойствах прибора (вкладка "Общие") задан неверный серийный номер, то при попытке опросить прибор выдается сообщение об ошибке.


Групповой опрос приборов

Групповой опрос приборов предназначен для опроса в ручном режиме несколько приборов, зарегистрированных в базе данных, а также для контроля процесса опроса суточных архивов.

Для группового опроса приборов необходимо:

1. Установить курсор на надпись "Все приборы учета".

2. Выбрать команду "Опросить выбранные приборы учета...".

3. В окне "Выбор приборов" отображается перечень приборов, зарегистрированных в базе данных программы, а также дата последней суточной записи.

Если дата последней суточной даты в таблице меньше, чем текущая дата -1, то соответствующая ячейка подсвечивается. Таким образом, можно проконтролировать приборы, опрос которых не завершен.

Для опроса следует отметить необходимые приборы или нажать кнопку ВыбратьКрасные.

После нажатия кнопки "ОК" ход процесса считывания отображается в строке состояния.

Примечание Последовательность представления приборов учета в таблице "Выбор приборов" задается способом сортировки (см. "Сортировка приборов в списке".


Опрос приборов учета за интервал дат

Программа "Архиватор" в стандартном применении рассчитана на чтение архивных данных за весь диапазон дат, находящихся в памяти вычислителя. Это позволяет хранить в базе данных (файл Data.mdb) непрерывный архив.

Однако, в случае необходимости разовой проверки работоспособности тепловычислителя можно опросить тепловычислитель за определенный интервал времени.

Для этого необходимо:

1.Выбрать прибор учета из списка

2.При нажатой клавише Ctrl на клавиатуре по щелчку правой кнопки мыши выбрать команду "Опросить прибор учета (по датам)".

3. Выбрать требуемый диапазон дат.

4. Нажать кнопку ОК.


Автоматический опрос приборов учета

Программа позволяет опрашивать приборы в автоматическом режиме.

Для опроса приборов в автоматическом режиме следует на вкладке "Свойства прибора-Соединение" установить флажок "Разрешено в период с...по" и задать требуемый диапазон времени, в течение которого будет производиться опрос.

Опрос приборов производится в течение заданного диапазона один раз в сутки.

Диапазон опроса можно установить для каждого из приборов индивидуально или задать общий диапазон для всех приборов (см. Групповая запись свойств приборов).


Монитор обмена

Монитор обмена предназначен для отображения на экране служебной информации, передаваемой по линиям связи между вычислителем и компьютером.

Для отображения служебной информации необходимо на панели меню в меню "Вид" задать команду "Монитор обменов".

На экран выводится специальное окно, в котором отображается процесс обмена информацией.

Примечание Вкладка "Монитор 1" используется для записи обращений к прибору при ручном обращении к вычислителю.
Вкладки "Монитор 2...Монитор6 - при автоматическом опросе (опросе по расписанию).

Операции, допустимые в мониторе обмена:

·Очистка содержимого окна монитора обмена.

Команда предназначена для очистки содержимого окна "Монитор обменов".

В меню "Операции" выбрать команду "Очистить содержимое".

·Сохранение содержимого окна на компьютер в текстовом формате.

Команда предназначена для сохранения логов обмена в текстовый файл для последующего анализа.

В меню "Операции" выбрать команду "Сохранить содержимое как...". В раскрывшемся окне выбрать путь сохранения файла и ввести название.


Приборы учета

Основным элементом системы является прибор учета.

Прибор учета – тепловычислитель ТВ7 или расходомер Питерфлоу РС.

Все параметры, считываемые из приборов заносятся в базу данных Microsoft Access (файл Data.mdb).

Допустимые действия при работе с приборами учета:

·Добавить прибор учета - запись в базу данных сведений о свойствах прибора (зав. номер, тип соединения, протокол обмена, название и адрес абонента);

·Свойства прибора учета - просмотр и редактирование сведений о свойствах прибора;

·Опросить прибор учета - чтение из прибора и запись в базу данных результатов измерений и событий;

·Удалить прибор учета - удаление из базы данных сведений о свойствах прибора, а также измеренных значений (архивов) по конкретному прибору;

·Очистить базу данных для прибора учета - удаление из базы данных измеренных значений (архивов) по конкретному прибору;

·Удалить все приборы учета - удаление из базы данных сведений о свойствах и измеренных значений (архивов) по всем приборам;

·Очистить базу данных для всех приборов - удаление из базы данных измеренных значений (архивов) по всем приборам;

Указанные действия доступны в меню "Приборы учета" на панели меню или при нажатии правой кнопки указателя при выборе конкретного прибора.

Содержимое базы данных по приборам учета может быть выведено для просмотра на экране компьютера, а также используется для формирования отчетов о тепло- и водопотреблении (см. Формирование отчетов).

Базы данных с результатами измерений, хранящиеся на разных компьютерах, могут быть синхронизированы (см. Импорт данных).


Добавление прибора учета

Для добавления записи в базу данных сведений о свойствах нового прибора необходимо:

1. Установить курсор на надпись "Все приборы учета";

2. Нажать правую кнопку мыши и выбрать команду "Добавить прибор учета...".

3. Или на панели меню выбрать пункт "Приборы учета" и команду "Добавить прибор учета...".

4. Заполнить поля свойств прибора учета (см. Свойства прибора учета).

Примечание При первом подключении тепловычислителя ТВ7 к компьютеру по USB программа автоматически предлагает добавить в базу данных свойства прибора. При этом автоматически записываются тип прибора и его серийный номер.


Свойства прибора учета

К свойствам прибора относятся параметры, используемые для идентификации прибора в базе данных (зав. номер), организации считывания данных из прибора (тип соединения, протокол обмена) и привязки отчетов о тепло- и водопотреблении к конкретному абоненту (название и адрес абонента).

Свойства прибора учета разделены на 2 группы:

- общие свойства;

- соединение.

Отличия в свойствах для тепловычислителя ТВ7 и расходомера Питерфлоу РС состоят в дополнительных параметрах соединения.

Общие свойства прибора учета

К общим свойствам прибора учета относятся:

- тип прибора (ТВ7, Питерфлоу РС или АДИ);

- серийный номер прибора;

- название абонента;

- адрес и телефон потребителя.

Тип соединений

Допустимы следующие типы соединений с прибором:

- Прямое соединение по последовательному каналу (интерфейсы RS232 или RS485);

- Модемное соединение;

- Соединение по Ethernet/Internet.

При установке флажка "Соединение по расписанию" программа автоматически считывает данные из прибора в заданный интервал времени.

Примечание Опрос прибора по расписанию выполняется ТОЛЬКО один раз в сутки.

Примечание Независимо от типа соединения и настроек при подключении вычислителя ТВ7 к ПК по USB считывание данных происходит автоматически.

Прямое соединение

Примечание Скорость обмена при работе с расходомером Питерфлоу РС 19200 бит/с.

Примечание При работе от батареи максимальная скорость обмена с вычислителем ТВ7 составляет 9600 бит/с.

Модемное соединение

Настройки аналогичны прямому соединению. Дополнительно требуется ввести телефонный номер модема.

Соединение Ethernet/Internet

Примечание Установка номера IP порта:
- при работе с вычислителем ТВ7 номер порта равен 5001;
- при работе с расходомером через адаптер Ethernet производства ЗАО ТЕРМОТРОНИК номер порта равен 502 или 503 в зависимости от канала адаптера.


Дополнительные параметры соединения

Дополнительные параметры вычислителя ТВ7

Сетевой адрес при работе с одним прибором устанавливать равным нулю.

Если нет необходимости считывать часовые архивы, то можно снять флажок "Читать часовой архив".

Примечание Скорость обмена, сетевой адрес и тип транспортного протокола должны совпадать с настройками вычислителя.

Примечание Транспортный протокол при прямом соединении может быть любым. При модемном соединении - Modbus ASCII или РРР.

Дополнительные параметры расходомера Питтерфлоу РС

В дополнительных настройках соединения для Питерфлоу РС могут быть установлены:

- сетевой адрес прибора. Используется при подключении нескольких расходомеров к одному каналу связи.

- флажок USB<>LIN. Используется при подключении Питерфлоу РС к ПК через адаптер USB. См. Особенности подключения Питерфлоу РС.

- флажок "Читать архивы событий и диагностик". Устанавливается в случае необходимости сохранения в базе данных содержимого фискальных архивов расходомера.

- флажки "Читать минутный/часовой архив". Применяется в случае необходимости сохранения в базе данных архива с минутными и/или часовыми записями.

- флажок "Подключен через АДИ". Устанавливается при необходимости одновременного чтения архивной информации из Питерфлоу РС и адаптера АДИ с заданным серийным номером. См. Особенности подключения Питерфлоу РС. При установке данного флажка следует задать дополнительные параметры соединения адаптера АДИ.

Дополнительные параметры адаптера АДИ

В дополнительных настройках соединения для адаптера АДИ могут быть установлены:

- сетевой адрес прибора. Используется при подключении нескольких адаптеров к одному каналу связи.

- флажки "Читать часовой архив". Применяется в случае необходимости сохранения в базе данных архива с часовыми записями.


Сортировка приборов в списке

По умолчанию все приборы в списке отображаются в порядке их записи в базу данных.

В случае необходимости, последовательность представления приборов можно изменить, отсортировав их по серийным номерам или названию абонента.

Для этого необходимо в меню "Вид" выбрать команду "Сортировка списка приборов" и выбрать способ сортировки.


Групповая запись свойств приборов

Для приборов, зарегистрированных в базе данных, можно задать общие параметры соединения:

- время опроса по расписанию;

- необходимость чтения часовых и фискальных архивов;

- номер Com-порта компьютера и скорость передачи данных.

Для групповой записи свойств необходимо:

1. Установить курсор на надпись "Все приборы учета".

2. Выбрать команду "Изменить для всех приборов учета...".

3. В раскрывшемся окне ввести требуемые значения параметров по каждому из типов приборов и нажать кнопку "Задать".

Примечание В силу вступают только те группы параметров, для которых была нажата кнопка "Задать".


Особенности подключения Питерфлоу РС

Расходомер Питерфлоу РС допускает различные способы подключения к компьютеру системы верхнего уровня.

Варианты подключения Питерфлоу РС к персональному компьютеру | Основные параметры соединения
ПФ СхемаСвязи 2 | Тип соединения - Ethernet/Internet IP адрес - ХХХ IP порт - 502 или 503
ПФ СхемаСвязи 1 | Тип соединения - Прямое Скорость обмена 19200
ПФ СхемаСвязи 3 | Тип соединения - Прямое Скорость обмена 19200 Флажок USB<>LIN - Есть Необходима установка драйвера виртуального Com-порта (скачать можно здесь)
ПФ СхемаСвязи 4 | Тип соединения - Прямое Скорость обмена 9600/19200 (равно скорости адаптера АДИ)
ПФ СхемаСвязи 5 | Тип соединения - Модем Скорость обмена ХХХ (равно скорости местного модема)
ПФ СхемаСвязи 6 | Тип соединения - Модем Скорость обмена ХХХ (равно скорости местного модема)

Примечания:

1. ХХХ - любое значение.

2. Установка флажка "Подключен через АДИ" (Свойство прибора учета - Соединение - Дополнительно) позволяет считывать архивные данные из АДИ при отправке команды "Опросить прибор" на Питерфлоу РС.


Очистка базы данных

Накопленные архивные данные приборов учета могут быть удалены из базы данных.

Удаление архивных данных приборов учета из базы возможно двумя способами:

- удаление данных всех приборов;

- удаление данных конкретного прибора.

Удаление архивов всех приборов учета

Чтобы удалить из базы архивы всех приборов учета необходимо:

1. Установить курсор на надпись "Все приборы учета" и нажать правую кнопку мыши.

2. Выбрать команду "Очистить базу данных для всех приборов учета".

3. Или на панели меню выбрать пункт "Приборы учета" и команду "Очистить базу данных для всех приборов учета".

4. Подтвердить факт удаления данных:

Удаление архива конкретного прибора учета

Чтобы удалить из базы архивы конкретного прибора учета необходимо:

1. Установить курсор на конкретный прибор учета и нажать правую кнопку мыши.

2. Выбрать команду "Очистить базу данных для прибора учета".

3. Или на панели меню выбрать пункт "Приборы учета" и команду "Очистить базу данных для прибора учета".

4. Подтвердить факт удаления данных:


Очистка архивов

По мере расширения количества приборов и времени эксплуатации база данных (файл Data.mdb) увеличивается в размерах, что приводит к замедлению работы.

Архивные данные в базе данных можно по мере необходимости удалять, тем самым уменьшать объем базы данных.

Для удаления архивных данных необходимо:

1.Установить курсор на "Все приборы учета".

2.При нажатой клавише Ctrl на клавиатуре по щелчку правой кнопки мыши выбрать команду "Очистить архив...".

3.В раскрывшемся окне выбрать дату, до которой из базы данных будут удалены все архивные данные (часовые, суточные, месячные и итоговые значения).

4.Нажать кнопку "Удалить".

Примечание При очистке базы данных текущие данные, а также данные фискальных архивов НЕ УДАЛЯЮТСЯ.


Удаление приборов учета

Записи о приборах учета, а также архивные данные в базе данных могут быть удалены.

Возможно удалить данных как по конкретному прибору учета (команда "Удалить прибор учета"), так и по всем приборам одновременно - очистка базы данных (команда "Удалить все приборы учета").

Удаление данных по всем приборам учета

Чтобы удалить из базы записи о всех приборах учета необходимо:

1. Установить курсор на надпись "Все приборы учета" и нажать правую кнопку мыши.

2. Выбрать команду "Удалить все приборы учета...".

3. Или на панели меню выбрать пункт "Приборы учета" и команду "Удалить все приборы учета...".

4. Подтвердить факт удаления данных о всех приборах учета в базе данных.

После выполнения данной команды база данных будет полностью очищена, включая параметры настройки и архивные данные всех приборов.

Удаление данных по конкретному прибору учета

Чтобы удалить из базы запись по конкретному прибору учета необходимо:

1. Установить курсор на конкретный прибор учета и нажать правую кнопку мыши.

2. Выбрать команду "Удалить прибор учета...".

3. Или установить курсор на конкретный прибор учета и на панели меню выбрать выбрать пункт "Приборы учета" и команду "Удалить прибор учета...".

4. Подтвердить факт удаления данных о приборе учета:

Примечание При удалении записей из базы о приборе учета автоматически удаляются и все архивные данные приборов.


Формирование отчетов

Все данные, считанные из вычислителей, расходомеров и регистраторов АДИ, хранятся в единой базе данных (файл Data.mdb).

Содержимое архивов можно просмотреть на экране компьютера.

Для этого необходимо выделить прибор учета и требуемый тип архива.

В окне просмотра данных архива (в правой части экрана) отображаются:

- диапазон дат архива, записанного в базу данных;

- значения параметров;

- коды нештатных ситуаций.

Примечание Параметры, по которым в архиве зафиксирована нештатная ситуация, выделяются цветом.

Можно изменять систему единиц (СИ или МКС) для отображения данных по давлению и тепловой энергии.

Для перемещения по окну просмотра можно использовать колесико (скролл) мыши или кнопки:

· ArchivBut-01 - перемещение в начало архива.

· ArchivBut-03 или ArchivBut-04 - перемещение на 1 позицию вверх или вниз.

· ArchivBut-02 или ArchivBut-05 - перемещение на 20 позиций вверх или вниз.

· ArchivBut-06 - перемещение в конец архива.


Шаблоны отчетов

Форма отчетов о тепло- и водопотреблении определяется выбранным шаблоном отчета.

Шаблон отчета — определяет перечень параметров и порядок их вывода в в отчет о тепло- и водопотреблении.

По умолчанию используется шаблон Стандарт, в котором перечислены все возможные параметры, измеряемые прибором.

Примеры шаблона отчета вычислителя и сформированного на его основе отчета приведен ниже.

Шаблоны отчетов хранятся в единой базе данных.

Все создаваемые шаблоны записываются в общий список шаблонов. Для вычислителя и расходомера списки разные.

Для каждого из приборов создается индивидуальный набор шаблонов из общего списка. Например, для тепловычислителя можно иметь разные шаблоны для каждого из тепловых вводов (ТВ1 и ТВ2).


Особенности шаблонов отчета

Особенности шаблона вычислителя ТВ7

Для формирования отчета о теплопотреблении для ТВ7 существует 2 стандартных шаблона:

- Стандарт М - для формирования отчета о потреблении ГВС по разности масс dM=М1-М2.

- Стандарт V - для формирования отчета о потреблении ГВС по разности объемов dV=V1-V2.

В шаблоне задаются:

·перечень параметров и последовательность их вывода в отчете;

·ширину столбцов отчета;

·способ отображения в отчете кодов нештатных ситуаций (НС).

Перечень параметров, выводимых в отчет по тепловому вводу:

·t1...t3 - средневзвешенные значения температур в трубопроводах Тр1...Тр3;

·dt - разность температур (t1-t2);

·V1...V3 - объемы за отчетный интервал в трубопроводах Тр1...Тр3;

·М1...М23 - рассчитанные массы за отчетный интервал в трубопроводах Тр1...Тр3;

·dM - разность масс (М1-М2);

·tx, Px - температура и давление холодной воды;

·tнв - температура наружного воздуха;

·Qтв - суммарное тепло для теплового ввода;

·Q12 - тепло для трубопроводов 1 и 2;

·Qг - тепло ГВС;

·ДП - значение по дополнительному импульсному входу;

·ВНР - время нормальной работы;

·ВОС - время остановки счета;

·НС - индикатор нештатных ситуаций.

Примечание Независимо от перечня параметров в шаблоне отчета параметры, отсутствующие в выбранной схеме измерений в тепловом вводе, в отчете не отображаются.

Особенности шаблона расходомера Питерфлоу РС

В шаблоне задаются перечень параметров и последовательность их вывода в отчете.

Перечень параметров, выводимых в отчет:

где:

·V+ итог - итоговый накопленный объем в прямом направлении;

·V+ - накопленный объем в прямом направлении за отчетный интервал;

·V- итог - итоговый накопленный объем в обратном направлении;

·V- - накопленный объем в обратном направлении за отчетный интервал;

·Траб.итог - суммарное время работы;

·Траб. - время работы за отчетный интервал;

·Траб.с НС итог - суммарное время работы с ошибкой;

·Траб.с НС - время работы с ошибкой за отчетный интервал;

·НС - коды нештатных ситуаций за отчетный интервал;

·Gmin - минимальное значение расхода на отчетном интервале;

·Gmax - максимальное значение расхода на отчетном интервале;

·Р1'...V+' - параметры архива регистратора АДИ, если Питерфлоу РС подключен через АДИ.

Особенности шаблона адаптера АДИ

В шаблоне задаются перечень параметров и последовательность их вывода в отчете.

Перечень параметров, выводимых в отчет:


Создание шаблона отчета

Шаблоны для формирования отчетов создаются на основе шаблона Стандарт который включает полный перечень параметров, измеряемых прибором.

Для создания (редактирования) шаблона необходимо:

1. Установить курсор на прибор учета и нажать правую кнопку мыши.

2. Выбрать команду "Шаблоны отчетов...".

Для формирования отчетов используются шаблон из списка в правой половине окна "Шаблоны отчетов" - Список шаблонов прибора учета.

Для создания и редактирования новых шаблонов используется левая часть окна - Список общих шаблонов.

Для копирования общего шаблона в список шаблонов для прибора учета необходимо выделить требуемый шаблон и нажать кнопку ShablonCopy .

Для удаления шаблона из списка следует выделить удаляемый шаблон и нажать кнопку ShablonDelete .

Подтвердить факт удаления шаблона из списка для прибора учета.

Примечание Удалить шаблон отчета "Стандарт" из списка шаблонов НЕЛЬЗЯ.

Создание общего шаблона отчета о теплопотреблении

1. Для создания общего шаблона отчета необходимо в окне окна "Шаблоны отчетов" нажать кнопку ShablonNewZnak .

На экране появится окно формирования шаблона.

В левой половине окна перечислены все измеряемые вычислителем параметры (шаблон "Стандарт").

В правой половине - параметры, перечисленные в создаваемом шаблоне.

По умолчанию (первоначально) создаваемый шаблон полностью соответствует шаблону "Стандарт".

2. Для удаления параметров, не используемых в шаблоне необходимо выделить параметры и нажать кнопку ShablonDelete .

Выделение нескольких параметров выполняется при нажатой клавише Ctrl клавиатуры.

3. Для добавления параметра в шаблон необходимо выделить параметр и нажать кнопку ShablonCopy

4. Для изменения порядка следования параметров в отчете следует выделить параметр и нажать кнопки ShablonUp или ShablonDown

5. В случае необходимости для каждого параметра можно изменить ширину столбца в отчете.

6. Задать способ отображения кодов нештатных ситуаций в отчете ("НС в столбцах").

При установленном признаке "НС в столбцах" в отчете справа от значения параметра будет отображаться код НС.

При снятом признаке "НС в столбцах" код НС в отчете отображаться не будет.

Независимо от установленного признака "НС в столбцах" в столбце "НС" отчета ВСЕГДА отображается признак наличия НС (звездочка), если за отчетный час/сутки/месяц в архиве зафиксирована хотя бы одна нештатная ситуация.

7. По окончании формирования отчета необходимо ввести имя шаблона и нажать кнопку ОК. Новый шаблон будет сохранен и помещен в список общих шаблонов.

При попытке сохранения шаблона без имени выводится диагностическое сообщение:

Редактирование общего шаблона отчета

Для редактирования существующего общего шаблона отчета необходимо в окне окна "Шаблоны отчетов" нажать кнопку ShablonEditZnak .

Последующие действия по редактированию шаблона полностью аналогичны пп 2-6 раздела "Создание общего шаблона отчета".

Удаление общего шаблона отчета

Для удаления шаблона из списка общих шаблонов необходимо в окне окна "Шаблоны отчетов" выделить требуемый шаблон и нажать кнопку ShablonDeleteZnak .

Затем подтвердить факт удаления шаблона:


Отчеты о теплопотреблении

Для формирования отчета о теплопотреблении необходимо:

1.Выбрать в главном окне программы требуемый тип архива прибора;

2.Нажать кнопку "Отчет".

В появившемся окне ввести (выбрать) необходимую информацию:

- Номер теплового ввода, по которому формируется отчет.

- Тип шаблона, на основе которого создается отчет.

- Диапазон дат архива.

- Признак вывода отчета одной таблицей.

Примечание При снятом признаке "Отчет в виде одной таблицы" отчеты разбиваются на части: часовой отчет - отдельно для каждых суток, суточный отчет - отдельно для каждого отчетного месяца.

3.Нажать кнопку "ОК".

На экране отобразится запрашиваемый отчет.

4.Сформированный отчет можно распечатать и сохранить на компьютере в формате Excel.

5.Перед выводом на печать необходимо настроить параметры печати и выбрать ориентацию страницы.


Отчет о настройках вычислителя

Настройки вычислителя считываются при каждом сеансе связи.

В случае если текущие настройки отличаются от предыдущих, то в базу данных дописывается новое значение.

Таким образом, в базе данных (наряду с архивами событий непосредственно в вычислителе) хранится вся история изменения настроек вычислителя.

Целостность и неизменность настроек вычислителя контролируется с помощью контрольной суммы настроек (КСН).

Для формирования отчета о настройках необходимо:

1. Установить курсор на название прибора учета.

2. В правом окне программы выбрать дату изменения настроек.

3. Для вывода на экран отчета о настройках и последующей печати и сохранения следует нажать кнопку "Отчет о настройках".

Сформированный отчет можно распечатать и сохранить на компьютере в формате Excel.


Отчет о событиях

Вычислитель имеет 3 архива событий:

- Архив изменения БД – фиксация действий, связанных с изменениями параметров настройки.

- Архив административных событий – фиксация стирания архивов, изменения настроек с ПК, разрешения/запрета доступа к настройкам.

- Диагностический архив – фиксация включения/отключения сетевого питания, технологических событий.

Объем каждого из архивов составляет 255 записей.

Для формирования отчетов по каждому из архивов следует:

1. Выделить требуемый тип архива для прибора учета.

2. Нажать кнопку "Отчет".

Последующие действия по печати и сохранению отчетов полностью аналогичны действиям при сохранении отчетов о теплопотреблении.


Отчеты о водопотреблении

Для формирования отчета о теплопотреблении необходимо:

1.Выбрать в главном окне программы требуемый тип архива прибора;

2.Нажать кнопку "Отчет".

3.Выбрать шаблон отчета и задать диапазон дат архива

4.Нажать кнопку "ОК".

На экране отобразится запрашиваемый отчет.

5.Сформированный отчет можно распечатать и/или сохранить на компьютере в формате Excel.


Отчет о настройках расходомера

Настройки расходомера считываются при каждом сеансе связи.

В том случае, если текущие настройки отличаются от предыдущих, то в базу данных дописывается новое значение.

Таким образом, в базе данных (наряду с архивами событий непосредственно в расходомере) хранится вся история изменения настроек.

Для формирования отчета о настройках необходимо установить курсор на название прибора учета и в правом окне программы выбрать дату изменения настроек.

Отчет о настройках можно просмотреть на экране ПК.


Отчет о событиях

Расходомер имеет нестираемый архив событий объемом 255 записей.

Для формирования отчета следует:

1. Выделить требуемый тип архива.

2. Нажать кнопку "Отчет".

Последующие действия по печати и сохранению отчетов полностью аналогичны действиям при сохранении отчетов о водопотреблении.


Отчеты о водопотреблении

Для формирования отчета о водопотреблении необходимо:

1.Выбрать в главном окне программы требуемый тип архива прибора;

2.Нажать кнопку "Отчет".

В появившемся окне ввести (выбрать) необходимую информацию:

- Номер теплового ввода, по которому формируется отчет.

- Тип шаблона, на основе которого создается отчет.

- Диапазон дат архива.

- Признак вывода отчета одной таблицей.

Примечание При снятом признаке "Отчет в виде одной таблицы" отчеты разбиваются на части: часовой отчет - отдельно для каждых суток, суточный отчет - отдельно для каждого отчетного месяца.

3.Нажать кнопку "ОК".

На экране отобразится запрашиваемый отчет.

4.Сформированный отчет можно распечатать и сохранить на компьютере в формате Excel.

5.Перед выводом на печать необходимо настроить параметры печати и выбрать ориентацию страницы.


Отчеты о настройках адаптера АДИ

Отчет о настройках адаптера АДИ можно просмотреть на экране ПК.

Настройки адаптера считываются при каждом сеансе связи.

В том случае, если текущие настройки отличаются от предыдущих, то в базу данных дописывается новое значение.

Таким образом, в базе данных (наряду с архивами событий непосредственно в АДИ) хранится вся история изменения настроек.

Для формирования отчета о настройках необходимо установить курсор на название прибора учета и в правом окне программы выбрать дату изменения настроек.


Отчеты о событиях адаптера АДИ

Адаптер имеет нестираемый архив событий объемом 1024 записи.

Для формирования отчета следует:

1. Выделить требуемый тип архива.

2. Нажать кнопку "Отчет".

Последующие действия по печати и сохранению отчетов полностью аналогичны действиям при сохранении отчетов о водопотреблении.


Импорт данных из базы Access

Программа позволяет добавлять (импортировать) данные от приборов учета, сохраненные на другом компьютере, в основную базу данных.

С этой целью предварительно следует перенести файл базы данных (Data.mdb) на основной компьютер.

Затем в меню "Действия" выбрать команду "Импорт данных-Из базы Access".

Выбрать файл базы данных, содержимое которого следует добавить в основную базу и нажать "Открыть".

В раскрывшемся списке приборов, входящих в импортируемую базу данных, выбрать приборы, требуемые для импорта данных и нажать "Начать".

Программа перенесет все данные по приборам учета (настройки, архивы и события) в основную базу данных.


Импорт данных из устройств переноса данных

Программа позволяет импортировать данные от приборов учета, сохраненные на внешних устройствах переноса данных (планшетный компьютер, накопительный пульт или SD-карта), в основную базу данных.

Планшетный компьютер, накопительный пульт или SD-карта подключаются к компьютеру.

Затем в меню "Действия" следует выбрать команду "Импорт данных-Из накопителя".

Выбрать каталог на внешнем устройстве переноса данных, содержимое которого следует добавить в основную базу и нажать "ОК".

Программа перенесет все данные по приборам учета (настройки, архивы и события) в основную базу данных.


Контакты

Сайт ЗАО «ТЕРМОТРОНИК»: www.termotronic.ru

Служба технической поддержки:

e-mail: support@termotronic.ru

тел. 8-800-333-10-34