Справка v0.00234813-13 UsefulUtils Discs Studio

UsefulUtils Discs Studio

Программа для записи данных (Data Storage), DVD-Video (miniDVD) и потокового аудио (AudioCD) на CD\DVD диски в системах Windows 98/Me/2000/XP/2003/Vista.

Функции и возможности:
Поддерживает SCSI, ATAPI, Parallel port, USB (1.1 and 2.0) and FireWire (IEEE 1394) устройства
При записи AudioCD поддерживает файлы форматов MP3, WMA9 (если установлен кодек WMP9 или WMP11Beta), ASF (для Windows 9x нужен кодек), OGG (если установлен кодек) и WAV файлы
При записи AudioCD поддерживает TAO, DAO/96 и DAO/16 режимы записи
При записи AudioCD полностью поддерживает CD-Text (пока CD-Text устанавливается программой)
При записи DVD-Video и miniDVD использует файловую систему UDF
Поддерживает запись на CD\DVD диски любой емкости
Записывает диски с поддержкой технологий "Записи На Лету", "Защиты Опустошения Буфера". Также существует проверка корректности записанных данных (при записи Digital Storage)
Поддерживаются технологии защиты опустошения буфера, такие как: JustLink, ExacLink, Seamless Link, BURN-Proof, Smart-Burn, Power Burn, Safe Burn
Определяет основную информацию о диске и устройстве
Работает во всех 32 разрядных ОС семейства Windows (кроме Win 95). Для работы требуется библиотека WNASPI32.DLL (присутствует в инсталляторе)

Системные требования:
Процессор, совместимый с Intel Pentium(R)
Память 32 Mb и больше
700 Kb свободного места на жестком диске
Операционная система Windows 98/Me/2000/XP/2003
Хотя бы один CD/DVD-R(W) привод

Программа UsefulUtils Discs Studio является полностью бесплатной для использования. Однако, если она Вам понравилась, то можете поддержать проект UUDS —


Описание программы

Главное окно программы

1. Главное меню программы (ГМ)
Через главное меню осуществляется управление программой, её настройка, вызов помощи и др.

2. Панель инструментов (ПИ)
Позволяет вызывать основные функции программы, используя для этого кнопки.

3. Панель управления приводом (ПУ)
Позволяет выбрать привод, который будет использоваться для работы. Так же содержит кнопку обновления состояния привода и кнопку извлекающую/задвигающую лоток устройства.

4. Шкала дискового пространства
Показывает информацию о заполненности диска.

5. Меню выбора диска
Выбор диска или системной папки (Рабочий Стол/Мои Документы) для окна менеджера файлов.

6. Менеджер файлов (МФ)
В этом окне происходит выбор файлов, которые затем будут перенесены для дальнейшего использования в лист записи.

7. Путь
Отображение пути к директории, которая на данный момент открыта в файловом менеджере.

8. Лист записи (ЛЗ)
Файлы содержащиеся в этом окне могут быть либо записаны на диск, либо использованы для создания ISO-образа диска.
Если в приводе присутствует диск, на котором уже есть данные, то лист записи будет разбит на верхнюю и нижнюю части. Верхняя часть будет содержать файлы, которые уже присутствуют на диске. В нижнюю часть вы можете добавить файлы, которые хотите дописать к уже имеющимся на диске.

9. Закладки
Переключением закладок осуществляется выбор функционала программы.

10. Журнал событий
Вывод информации о работе программы.


Описание программы -> Действия

Главное меню

Действия

Записать диск/Создать ISO-образ
Используйте это для инициации процесса записи диска (или создания ISO-образа).

Записать образ на диск
Используйте это для того, чтобы записать ранее созданный ISO-образ на диск.

Очистить диск
Очистка диска. Быстрая — очищается заголовочная TOC-таблица диска; Полная — очищается весь диск.

Остановить операцию
Остановка процесса записи диска/создания ISO/Извлечения сессии/Граба диска/Рипа трека.

Вид

Поменять панели местами
Смена положения панелей менеджер файлов слева, лист записи справа или наоборот.

Менеджер файлов
Показывать кроме листа записи окно менЕджера файлов.

Оставшееся место на диске
Отображает информацию об оставшемся месте на шкале дискового пространства.

Проценты на панели задач
При работе программы отображает текущий процент выполненной задачи в Панели Задач.

Главное меню
Показывать Главное меню.

Панель инструментов
Показывать Панель инструментов.

Текст кнопок на панели инструментов
Показывать ли текстовые пояснения к кнопкам на панели инструментов.

Журнал событий
Показывать окно журнала событий.

Стиль иконок панели инструментов:
Выбор иконок для панели инструментов.

Сервис

Установка времени диска
Настройка позволяет вручную установить время (а соответственно и Размер), используемого CD-R диска. Используется в двух случаях:
1. Использование HyperBurning (перезапись)
Включение этой опции позволяет записать на диск больше данных, чем официально заявлено производителем CD-R. Важный момент: привод должен поддерживать запись "короткого" Lead-Out. Официальный размер lead-out секции на диске составляет 90 секунд (6750 секторов), но диски обычно работают и когда в секции lead-out всего 150 секторов. Поэтому на любой диск можно дополнительно записать данные в размере 88 секунд (6600 секторов). Использовать HyperBurning возможно ТОЛЬКО при записи в режимах DAO и SAO.
2. Запись дисков CD-R 700+
Поскольку производители дисков не используют какие-либо стандарты определения дискового пространства для CD-R 700+ (вернее, каждый производитель делает это по-своему), то эта обязанность возлагается на пользователя. В случае необходимости записи дисков CD-R 700+, UUDS предоставляет возможность установки времени (а соответственно и Размера) диска вручную. Как и в случае с HyperBurning, запись производится только в режимах DAO и SAO.

Тестовый режим
Тестовый режим производит выбранные действия, но лазер записывающего устройства при этом выключен. Этот режим рекомендуется в тех случаях, если вы не уверены, что операция будет выполнена. Только для CD!

Информация о приводе
Показывает функциональные возможности активного привода.

Настройки
Доступ к настройкам программы.

Язык
Выбор языка используемого в интерфейсе программы.

?

Справка
Вызов справочной информации по программе.

О программе
Вывод информации о работе программы.

Пожертвование
Вызов страницы для пожертвований программы UUDS.


Настройки -> Интерфейс

Настройки

Интерфейс

Отображать проценты на панели задач
При работе программы отображает текущий процент выполненной задачи в Панели Задач.

Оставшееся место на диске
Отображает информацию об оставшемся месте на шкале дискового пространства.

Менеджер файлов
Показывать кроме листа записи окно менджера файлов.

Поменять панели местами
Смена положения панелей менеджер файлов слева, лист записи справа или наоборот.

Текст кнопок на панели инструментов
Показывать ли текстовые пояснения к кнопкам на панели инструментов.

Журнал событий
Показывать журнал событий.

Иконки для exe, lnk, ico в листе записи
При добавлении в лист записи файлов с расширениями «EXE/LNK/ICO», им будут сопоставляться реальные иконки на жестком диске, иначе иконка «Приложение Windows». Время добавления при включеной настройке увеличится.

Отображать скрытые и системные файлы
Отображать скрытые и системные файлы в окне менеджера файлов

Панель инструментов
Показывать панель инструментов

Главное меню
Показывать главное меню

Расширенный лист записи
Данная настройка добавляет название столбцов в листе записи и дает возможность показать два дополнительных столбца — Источник и Размер.

Стиль иконок панели инструментов:
Выбор иконок для панели инструментов.

Запись

Обрезать расширения для длинных имен файлов
Используется при записи в ISO9660+JOLIET и ISO9660/Level2. По стандарту суммарная длина имени файла для JOLIET не более 107 символов, для Level2 не более 31, включая все спецсимволы. Таким образом, для файлов превышающих это ограничение и при включенной настройке, расширение будет обрезаться до 3х символов с использованием «~», а имя будет использовать оставшееся до ограничения число символов.
При отключенной настройке, расширение файла сохраняется.

Показывать работу буфера привода
При записи дисков будет отображаться процесс использования буфера привода.

Очищать задание после записи
После окончания записи, подготовленный проект из листа записи будет удаляться.

Использовать быстрое чтение TOC
При включенной настройке, чтение информации о конце записанных треков приблизительна, точна только информация о начале трека.

Записывать скрытые и системные файлы
При включенной настройке, будет производиться запись скрытых и системных файлов и папок.

Отображать оставшееся время до конца записи
Отображать оставшееся время до конца записи.

Приоритет записи:
Позволяет установить системный приоритет программы, а как следствие процесса записи.

Кеш данных для записи:
Кеш данных для записи — это выделяемая память для создания виртуального образа записываемого диска. Чем оно больше, тем вероятность опустошения буфера привода меньше. Однако при большом значении кеша, остановка записи крайне сложна, поскольку пока кеш не станет пустым, остановка не возможна.
Кеш для данных записи
На данном примере число 16 — множитель, 2 Mb — кеш привода, 32 Mb — используемый в программе кеш привода (должен быть кратен кешу привода).

Метод доступа к приводу:
Вы можете использовать один из трех возможных методов для работы с приводом (в зависимости от того, какие присутствуют у вас в системе). Подробнее о различиях в работе интерфейсов читайте в FAQ

Языковые настройки

Язык программы
Выбор языка, на котором будет работать программа.

Шрифт
Выбор шрифта.

Размер шрифта
Выбор размера шрифта.

Набор символов
Выбор набора символов шрифта.

Разное

Запоминать расположение окна при выходе
При следующем запуске окно программы будет открыто в том же месте, где оно в последний раз было закрыто и будет иметь те же размеры.

Сделать окно «Поверх всех»
Отображать окно поверх всех.

Автообновление состояния привода
Программа автоматически реагирует на системное сообщение при извлечение или вставке диска в привод. В Windows 2000/XP/2003/Vista/2008 должна быть запущена служба «Определение оборудования оболочки» (Shell Hardware Detection).

Добавить запись в меню «Отправить
Добавляет в пункт «Отправить» контекстного меню проводника Windows возможность оправки данных в программу UUDS.

Разрешить отмену для R-дисков
Дает возможность отменять начатую запись при работе с неперезаписываемыми дисками.

Использовать диск «заглушку
Дает возможность работы с листом записи при отсутсвующем диске в приводе.

Буфер для извлечения сессии
Задается размер буфера данных, используемого в операции «Извлечение сессии».

Разрешить удаление в Менеджере Файлов
Настройка дает возможность использовать системное удаление (Shift+)Delete в Менеджере Файлов.


Работа с программой


Работа с программой -> Запись данных на CD/DVD

Запись данных на CD/DVD

Закрыть диск
Закрывает диск для дозаписи.

Проверка диска после записи
При включении данной опции после записи диска будет произведено побайтовое сравнение виртуального образа и образа на диске. При использовании режимов DAO и SAO перед проверкой диск будет извлечен, поскольку информация при использовании этих режимов «схватывается» системой только после перезагрузки диска в привод. При нахождении ошибки, проверка прерывается.

Скорость записи
Выбор скорости для записи диска.

Защита от опустошения буфера
Данная возможность поддерживается большинством современных приводов, благодаря которой будет возможно продолжение записи даже если произойдет ошибка при работе буфера. Данная функция у разных производителей называетя по-разному, например: Yamaha Lossless-Link, Sanyo BURN-Proof, Ricoh Just-Link и т.д.

Метод записи
Выбор метода используемого для записи диска: TAO, SAO, DAO/96 и DAO/16. Подробнее о методах читайте в FAQ.


Работа с программой -> Запись Аудио-CD

Запись Аудио-CD


Работа с программой -> Запись DVD-Видео/miniDVD

Запись DVD-Видео/miniDVD


Работа с сессиями и треками


Работа с программой -> Горячие клавиши

Общие:
Ctrl+R — обновление состояния привода
Ctrl+E — извлечение/загрузка диска
Ctrl+L — информация о выбранных элементах в Листе Записи и ФМ
Ctrl+O — добавить аудио-файлы или папку DVD-Video
Ctrl+Alt+H — окно настроек HyperBurning
Ctrl+Alt+T — включение/выключение тестового режиме
Delete — удаление элемента активного задания (курсор на Листе Записи)
Shift+Delete — очистка активного задания
Ctrl+< — предыдущая закладка
Ctrl+> — следующая закладка

Панель инструментов:
F2 — запись диска
Ctrl+Alt+F2 — запись образа
F8 — очистка диска
Ctrl+F8 — «быстрая» очистка (без появления окна выбора режима)
ESC — отмена операции
Ctrl+P — окно настроек программы
Ctrl+I — информация о приводе/диске
Ctrl+U — окно «О программе...»
Ctrl(Alt)+F4 — выход

Файловый менеджер (ФМ):
F5 — добавление файла/каталога в Лист Записи
F7 — создание новой папки
Enter — вход в каталог
Backspace — выход из каталога на один уровень вверх
Space — подсчет занимаемого каталогом места
Alt+F1 — смена диска
Shift+F6 — переименование файла/каталога
Delete — удаление файла/каталога в Корзину
Shift+Delete — удаление файла/каталога с диска
Ctrl+\ — выход в корневую директорию диска
Ctrl+A — выделение всех элементов
Ctrl+C — копирование файла/каталога в буфер
Ctrl+X — «вырезание» файла/каталога в буфер
Ctrl+V — вставка файла/каталога из буфера


FAQ

FAQ (Frequently Asked Questions) часто задаваемые вопросы

Вопрос: В настройках записи есть возможность выбрать ASPI, SPTI и SPTD. Что это такое?
Ответ: ASPI, SPTI и SPTD — это методы доступа программы для работы с приводом. В ОС Windows по умолчанию программы используют интерфейс SPTI (библиотека которого присутствует в системе изначально) для связи с устройствами. В комплекте с программой идет библиотека ASPI, для работы с которым она и делалась. Так же в системе может быть дополнительно установлен SPTD.

ASPI (Advanced SCSI Programming Interface) — расширенный интерфейс программирования SCSI. Спецификация разработана компанией Adaptec для возможности разработки программистами драйверов устройств и других программ, которые работают с такими устройствами как сканеры, принтеры и запоминающие устройства. ASPI определяет единый набор правил, которые можно использовать чтобы выполнять задачи «коммуникации» с устройствами SCSI.
ASPI Layer
Стандартный набор программного обеспечения для связи ASPI драйверов устройств и программного менеджера ASPI, который должен быть написан для определённого контроллера, например, контроллера запоминающего устройства.

SPTI (SCSI Pass Through Interface) — технология прямой связи со SCSI-совместимыми устройствами для ОС Windows 2000 и старше. Разработана компанией Microsoft. Для обеспечения работы, в основном, используется функция WinAPI DeviceIOControl.

SPTD (SCSI Pass Through Direct) — это новый метод доступа к запоминающим устройствам, который был разработан компанией Duplex Secure Ltd.
В основном, SPTD подобен другим методам доступа, такими как ASPI от Adaptec или SPTI от Microsoft, которые обеспечивают доступ к запоминающим устройствам, но SPTD имеет намного больше особенностей, которые делают этот интерфейс уникальным.
Главная особенность SPTD — это его способность обеспечивать прямое управление устройствами без риска внедрения стороннего кода (возможно злонамеренного) сторонними драйверами-фильтрами или другими «rootkit»-приложениями, которые распространены сегодня. Это и есть основная цель разработки SPTD для организаций и приложений, где он в настоящее время используется.
Если Ваше приложение привязано к SPTD, то тогда наиболее вероятно, что оно не будет работать без SPTD (пожалуйста, консультируйтесь с изготовителем приложения для получения более подробной информации).
SPTD, в настоящее время, поддерживается только для ОС Microsoft Windows 2000 и выше. SPTD (подобно другим методам доступа), по умолчанию, не удаляется с Вашей системы после деинсталляции приложения, которое использовало SPTD, чтобы не нарушить работу других приложений, которые могут использовать SPTD! Это также позволит пользователю избежать ненужных перезагрузок системы, если будет производиться повторная попытка установки SPTD (например, с новым приложением).
Вопрос: В начале записи программа предлагает выбрать режим записи ISO9660 (MODE1 CDDD и MODE2 XA), ISO9660+Joilet или UDF 1.02. Чем эти стандарты отличаются друг от друга?
Ответ: ISO9660 — кроссплатформенный формат хранения информации на оптических носителях (принятие спецификации 1988 год).
Существуют следующие форматы записи, поддерживаемые UUDS:
— Mode 1: Используется в подавляющем большинстве CD-ROM, размер логического сектоpа равен 2048 байт (полезная инфоpмации), еще 288 байт используются для записи кодов EDC/ECC (коды коррекции ошибок).
— Mode 2: На PC pаспpостpанен очень мало, в связи с трудностями при работе с кластерами не кратними 512. Размер логического сектоpа равен 2336 байт, из которых 8 байт подзаголовка (SubHeader), 4 байта EDC и 276 байт ECC, соответственно оставшиеся 2048 — записываемые данные.

Оpганизация файловой системы по стандаpту ISO9660, имеет 3 уровня:
Level1:
— DOS-формат имен файлов
— Для имен используется только верхний регистр букв, числа и символ «_»
— Файловые имена не могут начинаться и заканчиваться «.»
— Файловые имена не могут иметь более одной «.»
— Длина имени папки не более 12 символов
— Максимальная глубина вложения папок — 32
— Ограничение на размер файла. Базовое ограничение 2 ГБ, однако иногда, если позволяет ОС, могут использоваться файлы до 4 ГБ. (Например, MacOS, файлы >2ГБ не видит, нужен спец дравер)
Level2:
— Снято ограничение DOS-формата имен файлов, однако ограничения все же существуют: 1. Имя — не более 30 символов; 2. Расширение — не более 30 символов; 3. Сумма символов Имя и Расширение — не более 30 символов.
— Для имен используется только верхний регистр букв, числа, символы «_» и пробел
— Длина имени папки не более 31 символа
— Максимальная глубина вложения папок — 8
— Ограничение на размер файла. Базовое ограничение 2 ГБ, однако иногда, если позволяет ОС, могут использоваться файлы до 4 ГБ. (Например, MacOS, файлы >2ГБ не видит, нужен спец дравер)
Level3 (не поддерживается UUDS):
— Файлы могут быть фрагметированными
— Ограничение на размер файла. Базовое ограничение 2 ГБ, однако иногда, если позволяет ОС, могут использоваться файлы до 4 ГБ. (Например, MacOS, файлы >2ГБ не видит, нужен спец дравер)
Как видно из вышесказанного, формат ISO9660 обладает весьма ограниченными возможностями и не отвечает требованиям современного компьютерного мира. Поэтому появились расширения ISO9660: Joliet и RockRidge (не поддерживается UUDS).
Joliet — расширение стандарта ISO9660, разработанное Microsoft для Windows 95, позволяющее записывать файлы с длинными именами.

UDF — Универсальный Дисковый Формат (с англ. Universal Disc Format) является спецификацией формата файловой системы хранения файлов на оптических носителях. Выполнен по стандарту ISO/IEC 13346 (также известному, как ECMA-167). Считается, что UDF — это замена ISO9660, и сегодня он широко используется для записи R(W)-дисков. UDF разрабатывается и поддерживается ассоциацией OSTA — Optical Storage Technology Association (http://www.osta.org).
Ревизии UDF:
1.00 (24 октября 1995)
Первый Оригинальный Выпуск
1.01 (3 ноября 1995)
Добавлена поддержка DVD
1.02 (30 августа 1996)
Этот формат используется DVD-Video дисками. Первая широкоиспользуемая версия UDF.
1.50 (4 февраля 1997)
Добавлена поддержка перезаписываеммых носителей типа CD-R/DVD-R, т.е. CD-RW/DVD-RW.
2.00 (3 апреля 1998)
Добавлена поддержка Потоковых файлов, файлов реального времени (для записи DVD) и упрощенное управление папками. Расширена поддержка VAT (Virtual Allocation Table). Используется ECMA-167 третьей редакции.
2.01 (15 марта 2000)
Главным образом, является bugfix для UDF 2.00. Многие двусмысленности UDF стандарта были решены в версии 2.01.
2.50 (30 апреля 2003)
Добавлена поддержка разделов meta-данных, что позволяет более просто восстанавливать данные после краха и дополнительно дублировать информации файловой системы.
2.60 (1 марта 2005)
Добавлены метод Псевдо Наложения Записей для дисков, поддерживающих псевдо наложения записей. Незначительные редакционные исправления.

Вопрос: Чем отличаются друг от друга режимы записи DAO, TAO и SAO?
Ответ:
Disk At Once (DAO)
Режим записи, когда диск записывается за один заход от начала до конца без прерываний. Сначала на диск записывается информация, отмечающий начало записи (lead-in), затем непосредственно сами данные, а в конце — финальная информация (lead-out). Метод предпочтителен в том случае, когда CD является источником информации для создания матрицы и в дальнейшем будет передан для тиражирования на завод. Запись в режиме DAO позволяет избежать связок входных (run-in) и выходных (run-out) блоков, которые ассоциируются с мультисессионной (multisession) записью. При записи AudioCD в режиме DAO исчезают паузы между условными дорожками.

DAO/16
Запись в режиме DAO с использованием 16-байтовых субканальных данных PQ.

DAO/96
Запись в режиме DAO с использованием 96-байтовых субканальных данных RW.

Track At Once (TAO)
Этот режим позволяет записывать диск за несколько заходов. Первоначально на диск можно записать одну дорожку с информацией, затем другую и так далее. При каждой последующей записи на диске теряется некоторый объем информации, который резервируется под служебные данные. Максимальное число треков — 99. Минимальная длина трека — 300 блоков (порядка 600 кБ). При записи AudioCD в этом режиме диск должен быть закрытым, чтобы проигрывался и бытовых CD-плеерах.

Session At Once (SAO)
Режим по своим свойствам очень схож с режимом DAO, за тем исключением, что позволяет не закрывать диск. Чаще всего используется для записи дисков CD-Extra.


История версий


Контактная информация

Сайт программы: http://uus4u.com

Форум программы: http://ru.uus4u.com/forums

Электропочта: mtsv@newmail.ru

Пожертвование: http://ru.uus4u.com/products/uuds_donate/index.html


Благодарности

KOLnMCK:
Владимир Кладов
mdw
и всему KOLnMCK сообществу (www.kolmck.net)

Бэта-улучшайзеры:
Anergy — (Россия, г. Петрозаводск)
dmitry287
FateStar
Fraerok — Фомин Александр (Россия, г. Петрозаводск)
oxival
Random
SoulWar
и всему UsefulUtils TM сообществу

Перевод:
Evgeniy Klevakin — English
StayAtHome — Українська
Artnn — Беларуская

Заимствованные коды:
Марк Руссинович (Format DVD-RAM)
Salvatore Santagati (mdf2iso, pdi2iso, b5i2iso, cdi2iso)
Gregory Kokanosky (nrg2iso)

Ядро «движка»:
Rocket Division Software (www.rocketdivision.com)


Справка v0.00234813-13 UsefulUtils Discs Studio

UsefulUtils Discs Studio

Программа для записи данных (Data Storage), DVD-Video (miniDVD) и потокового аудио (AudioCD) на CD\DVD диски в системах Windows 98/Me/2000/XP/2003/Vista.

Функции и возможности:
Поддерживает SCSI, ATAPI, Parallel port, USB (1.1 and 2.0) and FireWire (IEEE 1394) устройства
При записи AudioCD поддерживает файлы форматов MP3, WMA9 (если установлен кодек WMP9 или WMP11Beta), ASF (для Windows 9x нужен кодек), OGG (если установлен кодек) и WAV файлы
При записи AudioCD поддерживает TAO, DAO/96 и DAO/16 режимы записи
При записи AudioCD полностью поддерживает CD-Text (пока CD-Text устанавливается программой)
При записи DVD-Video и miniDVD использует файловую систему UDF
Поддерживает запись на CD\DVD диски любой емкости
Записывает диски «На Лету», т.е. без создания файла образа на диске. Существует проверка корректности записанных данных (при записи Digital Storage и DVDVideo)
Поддерживаются технологии защиты опустошения буфера, такие как: JustLink, ExacLink, Seamless Link, BURN-Proof, Smart-Burn, Power Burn, Safe Burn
Определяет основную информацию о диске и устройстве
Работает во всех 32 разрядных ОС семейства Windows (кроме Win 95). Для работы требуется библиотека WNASPI32.DLL (присутствует в инсталляторе)

Системные требования:
Процессор, совместимый с Intel Pentium(R)
Память 32 Mb и больше
700 Kb свободного места на жестком диске
Операционная система Windows 98/Me/2000/XP/2003
Хотя бы один CD/DVD-R(W) привод

Программа UsefulUtils Discs Studio является полностью бесплатной для использования. Однако, если она Вам понравилась, то можете поддержать проект UUDS —