Этот плагин позволяет создать базу данных устройств

Для запуска зайдите в меню Plug-ins->Configuration.
Найдите в списке плагинов Client-Server, щелкните на нем правой кнопкой и в появившемся меню нажмите Load.
Если вы хотите чтобы этот плагин загружался автоматически при каждой загрузке NetView - выберите пункт Autoload->Yes.


Этот плагин позволяет создать базу данных устройств

Протокол обмена информацией между NetView hostlist sharing сервером и клиентом является простым и открытым для реализации в другом ПО. Ниже можно прочитать его описание, на сайте http://ww.killprog.com можно скачать исходники плагина NetView client-server на Borland C++ Builder. Итак, описание:
Процедура подключения:
После установки соединения клиент шлет серверу свой логин и пароль в следующей форме: "login#password\x0D\x0A" и все. Процедура логина на этом завершена.

Запрос списка хостлистов которые выдаст сервер:
Для этого клиент шлет на сервер следующий запрос: "listenum#\x0D\x0A"
Сервер в шлет ответ в виде "listenum#list1#theme1#ltype1#llength1#lspeed1#lnote1#w1[0]#w1[1]#...#w1[31]#$list2#...#$\x0D\x0A", то есть в виде совокупности строк в которых отдельные поля разделяются символом # а сами строки разделяются символом $. О завершении выдачи строки-списка хостлистов свидетельствует получение "\x0D\x0A" (перевод строки + установка начала строки)

Запрос списка хостов и их метапеременных:
Для этого клиент шлет на сервер следующий запрос: "hostenum#varname1#varname2#...varnameN#\x0D\x0A"
Ответ в формате "hostenum#host1#varname1_1=vardata1_1#...varname1_N=vardata1_N#$host2#varname2_1=vardata2_1#...varname2_N=vardata2_N#$\x0D\x0A",
Отметим что сервер может и не присылать значения некоторых переменных, если они не разрешены для чтения текущему логину

Запрос списка линий визуальной карты:
Для этого клиент шлет на сервер следующий запрос: "lineenum#\x0D\x0A"
Ответ в формате "lineenum#index1#x[0]#..#x[31]#y[0]#..#y[31]#nodes#color#flags#width#ltype#llength#lspeed#lnote#mapname#$...#$\x0D\x0A"
Если для данного логина запрещена выдача этой информации сервер шлет в ответ: "lineenum$\x0D\x0A"

Запрос списка областей визуальной карты:
Для этого клиент шлет на сервер следующий запрос: "areaenum#\x0D\x0A"
Ответ в формате "areaenum#left#top#right#bottom#color#hint#name#mapname#$....#$\x0D\x0A"
Если для данного логина запрещена выдача этой информации сервер шлет в ответ: "areaenum$\x0D\x0A"

Запрос списка всех .gif и .bmp файлов картинок из подкаталогов в \Themes с размером и временем последней записи каждого файла:
Для этого клиент шлет на сервер следующий запрос: "vimgenum#\x0D\x0A"
Ответ в формате: "vimgenum#imagefile1#size1_timelo_timehi#imagefile2#size2_timelo_timehi#...imagefileN#sizeN_timelo_timehi#$"
Если для данного логина запрещена выдача этой информации сервер шлет в ответ: "vimgenum$\x0D\x0A"

Запрос списка заданных .gif и .bmp файлов картинок из подкаталогов в \Themes с размером, временем последней записи и содержимого в бинарном виде каждого файла:
Для этого клиент шлет на сервер следующий запрос: "vimgdata#imagefile1#imagefile2#...imagefileN#"
Ответ в формате: "vimgdata#imagefile1#size1_timelo_timehi#rawdata1#imagefile2#size2_timelo_timehi#rawdata2#..imagefileN#sizeN_timelo_timehi#rawdataN#$"
Если для данного логина запрещена выдача этой информации сервер шлет в ответ: "vimgdata$\x0D\x0A"

Перед отправкой запросов и после принятия ответов (кроме содержимого файлов команды vimgdata) клиент должен определенным образом преобразовывать символы строк, таблица перекодировки символов в кодовые последовательности (в Сшном представленнии ESC последовательностей):
"\x0D" -> "\\1"
"\x0A" -> "\\2"
"\x00" -> "\\3"
"$" -> "\\4"
"#" -> "\\5"
"=" -> "\\6"
"\\" -> "\\7"
"\x09" -> "\\8"
" " -> "\\9"